POJ-1308 Is It A Tree?(直接写的题)

加油。
To be better.

题目链接:
https://cn.vjudge.net/problem/POJ-1308
题目:
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
POJ-1308 Is It A Tree?(直接写的题)
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入:
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
输出:
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入:
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
样例输出:
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题目大意:
给你一组两两成对的数组,一个前驱,一个后继,判断是否是树。遇到0 0结束一组输入,遇到-1 -1结束输入。

题目解析:
本题可利用树的定义来做,在树中,每个节点都有唯一的后继,如果两个节点有一个共同的后继,那么它就不是树;边数=节点数+1

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int f[1000];
//定义数组,数组值,1代表前驱,2代表后继
int main()
{
    int a,b,i,j,k,flag;
    while(1)
    {
        i=0,j=0,k=1,flag=1;
        memset(f,0,sizeof(f));
        while(cin>>a>>b&&a&&b)
        {
            if(a<0&&b<0)  //题意要求的结束判断
                return 0;
            if(f[b]==2)   //b是后继,但若是他以前已经是某个节点的后继,那么再成为另外一个节点的后继就不是树了,所以记录一下。
                flag=0;
            if(f[a]==0)  //记录节点数
                j++;
            if(f[b]==0) //记录节点数
                j++;
            f[a]=1;  //前驱记录为1
            f[b]=2; //后继记录为2
            i++;  //记录边的数量(每两个点有一条边

        }
        if(flag==1&&j==i+1)  //树的成立条件判断
            printf("Case %d is a tree.\n",k++);
        else
            printf("Case %d is not a tree.\n",k++);
    }
    return 0;
}

上一篇:5679. 一个图中连通三元组的最小度数


下一篇:PAT甲级1154Vertex Coloring