1036 Boys vs Girls (25 分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
 

Sample Output 1:

Mary EE990830
Joe Math990112
6
 

Sample Input 2:

1
Jean M AA980920 60
 

Sample Output 2:

Absent
Jean AA980920
NA
思路:同1006题,不过要注意性别
AC代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn=10010;
typedef struct students{
    string name;
    char gender;
    string id;
    int grade;
}stu;
int main(){
    stu st[maxn];
    int n;
    cin>>n;
    int highF=-1;
    int minM=101;
    int insF=-1,insM=-1;
    for(int i=0;i<n;i++){
        cin>>st[i].name;
        cin>>st[i].gender;
        cin>>st[i].id;
        cin>>st[i].grade;
        if(st[i].gender=='F'&&st[i].grade>highF){
            highF=st[i].grade;
            insF=i;
        }
        if(st[i].gender=='M'&&st[i].grade<minM){
            minM=st[i].grade;
            insM=i;
        }
    }
    if(insF!=-1){
        cout<<st[insF].name<<" "<<st[insF].id<<endl;
    }
    else{
        cout<<"Absent"<<endl;
    }
    if(insM!=-1){
        cout<<st[insM].name<<" "<<st[insM].id<<endl;
    }
    else{
        cout<<"Absent"<<endl;
    }
    if(insF==-1||insM==-1){
        cout<<"NA"<<endl;
    }
    else{
        cout<<highF-minM<<endl;
    }
    
    return 0;
}

 

上一篇:1036 Boys vs Girls


下一篇:js删除对象中的某一个字段的方法