2021-5-8【CCF】【1032. 菱形 】

题目描述
输入一个正整数n,输出用1至(2n-1)的数字组成的菱形。

输入
输入正整数n。

输出
输出对应的菱形(见样例)。

样例输入
3

样例输出

  1 
 123
12345
 123
  1

数据范围限制
1<=n<=10

#include<bits/stdc++.h>
using namespace std;

int main(){
	int n;
	cin>>n;
	for(int i=0;i<n;i++){
		for(int j=0;j<n-i-1;j++){
			cout<<" ";
		}
		for(int k=1;k<2*i+2;k++){
			cout<<k;
		}
		cout<<endl;
	}
	for(int i=n-2;i>=0;i--){
		for(int j=0;j<n-i-1;j++){
			cout<<" ";
		}
		for(int k=1;k<2*i+2;k++){
			cout<<k;
		}
		cout<<endl;
	}
	
}
上一篇:C语言程序设计【1032】


下一篇:信息学奥赛一本通(1032:大象喝水查)