1001. A+B Format

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

程序代码:*

#include<stdio.h>
int main()
{
  int a,b,sum;
  scanf("%d%d",&a,&b);
  sum=a+b;
  if(sum<0)
    printf("-");
  if(abs(sum)<1000)
  printf("%d",abs(sum));
  if(abs(sum)>=1000&abs(sum)<1000000)
  printf("%d,%03d",abs(sum)/1000,abs(sum)%1000);
  if(abs(sum)>=1000000&abs(sum)<=2000000) 
  printf("%d,%03d,%03d",abs(sum)/1000000,abs(sum)/1000%1000,abs(sum)%1000);
  return 0;
}

上一篇:ElasticSearch(九):springboot项目集成消息中间件activeMQ


下一篇:C#-安全