[PAT]1101 Quick Sort (25 分)(样例2段错误原因)

一、题意

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

 二、题解

题目大意是给出一段正数序列,判断哪几个数可能是在快速排序中当做中间值的数。即找出所有X,X满足,所有在X前的数都小于X,所有在X后面的数都大于X。

样例2段错误原因:有可能找不到这样的数,那么ans数组size就为0,那么就不能使用sort(ans.begin(), ans.end());进行排序了,所以需要判断ans数组的大小是否为0。

AC代码:

#include <bits/stdc++.h>
using namespace std;

vector<int > nums;
vector<bool > maxflag;
vector<bool > minflag;

int main() {
    int n;
    cin>>n;
    maxflag.resize(n+5);
    minflag.resize(n+5);

    for(int i=0; i<n; i++) {
        int temp;
        cin>>temp;
        nums.push_back(temp);
    }

    fill(maxflag.begin(), maxflag.end(), false);
    fill(minflag.begin(), minflag.end(), false);
    int maxnum;
    int minnum;
    maxnum = nums[0];
    minnum = nums[n-1];

    //判断nums[i]是否大于所有前面的数
    for(int i=0; i<n; i++) {
        if(nums[i] >= maxnum) {
            maxflag[i] = true;
            maxnum = nums[i];
        } else {
            ;
        }
    }
    //判断nums[i]是否小于所有后面的数
    for(int i=n-1; i>=0; i--) {
        if(nums[i] <= minnum) {
            minflag[i] = true;
            minnum = nums[i];
        } else {
            ;
        }
    }
    vector<int > ans;
    for(int i=0; i<n; i++){
        if(maxflag[i] && minflag[i]){
            ans.push_back(nums[i]);
        }
    }
    cout<<ans.size()<<endl;
    int m = ans.size();
    if(ans.size() == 0){
        cout<<endl;
        return 0;
    }

    sort(ans.begin(), ans.end());

    for(int i=0; i<ans.size()-1; i++){
        cout<<ans[i]<<" ";
    }
  
    cout<<ans[m-1]<<endl;
    return 0;
}

 

上一篇:Use the CSS Transform scale Property to Change the Size of an Element


下一篇:Effectively writing datatemplates