1035. Password (20)-PAT甲级真题

目录

首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

题目原文

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa   

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa   

Sample Input 2:

1
team110 abcdefg332    

Sample Output 2:

There is 1 account and no account is modified    

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333    

Sample Output 3:

There are 2 accounts and no account is modified

生词

confusing 混乱的

题目大意

就是给你若干个字符串,现在要你把容易看不清楚的字符串用对应的字符替换掉

数字1用@替换

数字0用%替换

字母O用o替换

小写l用大写L替换

对了,这题要注意下,单复数

代码如下

#include<iostream>
#include<cstring>
using namespace std;
int main(void) {
    string a[1010], c[1010];
    int Judeg[1010] = { 0 };
    int N, flag = 0, j = 0, N1;
    int sum = 0;
    cin >> N;
    N1 = N;
    while (N--) {
        cin >> c[j] >> a[j];
        flag = 0;
        for (auto &i : a[j]) {
            if (i == '0'){
                i = '%';
                flag = 1;
            }
            else if (i == 'O')
            {
                i = 'o';
                flag = 1;
            }
            else if (i == '1') {
                i = '@';
                flag = 1;
            }
            else if (i == 'l') {
                i = 'L';
                flag = 1;
            }
        }
        if (flag == 1) {
            sum++;
            Judeg[j] = 1;
        }
        j++;
    }
    if (sum == 0) {
        if(N1>1)
        cout << "There are " << N1 << " accounts and no account is modified";
        else
            cout << "There is " << N1 << " account and no account is modified";
    }
    else
        cout << sum;
    for (int i = 0; i < N1; i++) {
        if (Judeg[i] == 1) {
            cout << "\n";
            cout << c[i] + ' ' << a[i];
        }
    }
    return 0;
}
上一篇:多线程同步


下一篇:我的力扣算发721-账户合并