Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
* Line 1: Two space-separated integers: N and K
Output
* Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
Farmer John starts at point 5 and the fugitive cow is at point 17.
Sample Output
OUTPUT DETAILS:
The fastest way for Farmer John to reach the fugitive cow is to
move along the following path: 5-10-9-18-17, which takes 4 minutes.
好裸的bfs……n的规模才10w
原来还想的是二进制dp,结果发现我在没事找事……
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int n,m,head,tail=1;
int dist[500001];
int q[500001];
inline bool mark(int x)
{
return !(x<0||x>max(2*m+1,n+1));
}
int main()
{
freopen("catchcow.in","r",stdin);
freopen("catchcow.out","w",stdout);
scanf("%d%d",&n,&m);
memset(dist,-1,sizeof(dist));
q[1]=n;dist[n]=0;
while (head<tail)
{
head++;
int now=q[head]-1;
if(mark(now)&&dist[now]==-1)
{
q[++tail]=now;
dist[now]=dist[q[head]]+1;
}
now=q[head]+1;
if(mark(now)&&dist[now]==-1)
{
q[++tail]=now;
dist[now]=dist[q[head]]+1;
}
now=q[head]*2;
if(mark(now)&&dist[now]==-1)
{
q[++tail]=now;
dist[now]=dist[q[head]]+1;
}
if(dist[m]!=-1) {printf("%d",dist[m]);return 0;}
}
}