poj3259 bellman——ford Wormholes解绝负权问题

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 35103   Accepted: 12805

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

题目大意:虫洞问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b话费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到从前

解题思路:其实给出了坐标,这个时候就可以构成一张图,然后将回到从前理解为是否会出现负权环,用bellman-ford就可以解出了

#include<stdio.h>
#include<string.h>
#include<stack>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
int u,v,w;
}que[5400];
int n,m,wh;
int Count;
int inf=999999999;
int dis[5000];
bool bellman_ford(){
memset(dis,inf,sizeof(dis));
dis[1]=0;
int flag;
int a,b,c;
for(int i=1;i<n;i++){
flag=0;
for(int j=0;j<Count;j++){
a=que[j].u,b=que[j].v,c=que[j].w;
if(dis[b]>dis[a]+c){
dis[b]=dis[a]+c;
flag=1;
}
}
if(!flag)
break;
}
for(int j=0;j<Count;j++){
a=que[j].u,b=que[j].v,c=que[j].w;
if(dis[b]>dis[a]+c)
return true;}
return false;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
Count=0;
scanf("%d%d%d",&n,&m,&wh);
int t1,t2,t3;
for(int i=1;i<=m;i++){ scanf("%d%d%d",&t1,&t2,&t3);
que[Count].u=t1;
que[Count].v=t2;
que[Count].w=t3;
Count++;
que[Count].u=t2;
que[Count].v=t1;
que[Count].w=t3;
Count++;
}
for(int i=m+1;i<=m+wh;i++){
scanf("%d%d%d",&t1,&t2,&t3);
que[Count].u=t1;
que[Count].v=t2;
que[Count].w=-t3;
Count++;
}
if(bellman_ford())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}

  

上一篇:Bellman-Ford(可解决负权边)--时间复杂度优化


下一篇:Bellman-Ford算法——解决负权边