If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in [0,107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
思路
- 题意就是
G.S.K
形式的货币运算,公式为1G=17S, 1S=29K
,按照这个规则相加取余就好了
代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
int g1, s1, k1;
int g2, s2, k2;
cin >> g1 >> s1 >> k1 >> g2 >> s2 >> k2;
int g, s, k;
g = g1 + g2;
s = s1 + s2;
k = k1 + k2;
int t = k;
t = k % 29;
s += k / 29;
t = s % 17;
g += s / 17;
cout << g << "." << s << "." << k;
return 0;
}
引用
https://pintia.cn/problem-sets/994805342720868352/problems/994805416519647232