简单数论题型

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

#include <cstdio>
#include <cmath>
#include <cstring>
int n,ans;
int bb[1230],qu[10001],tt[10001];

int is_prime(int n)
{
	if(n<2||(n!=2&&n%2==0))
		return 0;
	int i=3;
	for(i=3;i<=sqrt(n);i+=2)
		if(n%i==0)
			return 0;
	return 1;
}

int main()
{
	int cnt=0;
	for(int i=2;i<10001;++i)
	{
		if(is_prime(i))
			qu[i]=1,bb[cnt++]=i;
		tt[i]=cnt;
	}
	while(scanf("%d",&n)&&n)
	{
		ans=qu[n];
		int i=2;
		int count=0,j=0;
		for(i=0;i<tt[n];i++)
		{
			if(bb[i]>n/2) 
				break;
			count=0;
			for(j=i;j<tt[n];++j)
			{
				count+=bb[j] ;
				if(count>=n)
				{
					if(count==n) 
						ans++ ;
					break ;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0 ;
}

上一篇:Co-prime(容斥原理求互素数个数)(模板)


下一篇:Leedcode2 统计素数个数(埃氏筛选法)