A registration card number of PAT consists of 4 parts:
the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10^4) and M (≤100), the numbers of cards and the queries, respectively.
Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.
After the info of testees, there are M lines, each gives a query in the format Type Term, where
Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:
for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.
Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
实现思路:
这是一道排序模拟题,就是要求多了一点,要按照题目要求来排序输出。
AC代码:
#include <iostream>
#include <unordered_map>
using namespace std;
const int N=10010;
int n,m,in[N],pre[N];
unordered_map<int,int> mp;
struct node {
int data;
node *l,*r;
};
node* build(int preL,int preR,int inL,int inR) {
if(preL>preR) return NULL;
node *root=new node;
root->data=pre[preL];
mp[root->data]=1;
int k;
for(k=inL; k<=inR; k++) {
if(in[k]==root->data) break;
}
int leftNodeNum=k-inL;
root->l=build(preL+1,preL+leftNodeNum,inL,k-1);
root->r=build(preL+leftNodeNum+1,preR,k+1,inR);
return root;
}
int LCA(node *root,int p,int q) {
if(root==NULL) return -1;
int l=LCA(root->l,p,q);
int r=LCA(root->r,p,q);
if(root->data==p||root->data==q) return root->data==p?p:q;//找到p或者q所对应结点时
if(l!=-1&&r!=-1) return root->data;//pq分处在当前结点左右子树的情况
return l!=-1?l:r;//哪棵子树找到祖先结点了就返回哪个结果
}
int main() {
cin>>m>>n;
for(int i=0; i<n; i++) scanf("%d",&in[i]);
for(int i=0; i<n; i++) scanf("%d",&pre[i]);
node *root=build(0,n-1,0,n-1);
while(m--) {
int a,b;
scanf("%d%d",&a,&b);
if(mp.count(a)==0||mp.count(b)==0) {
if(mp.count(a)==0&&mp.count(b)==0) printf("ERROR: %d and %d are not found.",a,b);
else if(mp.count(a)==0) printf("ERROR: %d is not found.",a);
else printf("ERROR: %d is not found.",b);
} else {
int ans=LCA(root,a,b);
if(ans==a||ans==b) printf("%d is an ancestor of %d.",ans==a?a:b,ans==a?b:a);
else printf("LCA of %d and %d is %d.",a,b,ans);
}
printf("\n");
}
return 0;
}