PAT 1019 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题目大意:给出两个整数a和b,问十进制的a在b进制下是否为回文数。是的话输出Yes,不是输出No。并且输出a在b进制下的表示,以空格隔开

/*
	其实很简单的一道题,只是这个题目也太难懂了吧,题目我翻译出来都读不懂
	N in base b 是N在b进制下吗?
	所以做题的时候不能只看题目,要结合输入输出样例,在读不懂的情况下去猜测题意
*/
#include <iostream>
using namespace std;
#include <vector>

int main(){
    int n, b;
    cin >> n >> b;
    vector<int> v;
    
    while(n){
        v.push_back(n % b); //从高位到低位保存 其实都一样
        n /= b;
    }
    
    bool flag = true; //标记
    
    for(int i = 0, j = v.size() - 1; i < v.size() / 2; i++, j--){
        if(v[i] != v[j]){
            flag = false;
            cout << "No" << endl;
            break;
        }
    }
    
    if(flag) cout << "Yes" << endl;
    for(int i = v.size() - 1; i >= 0; i--){
        if(i != 0)
            cout << v[i] << " ";
        else
            cout << v[i] << endl;
    }
    return 0;
}
上一篇:1019 General Palindromic Number (20 分)


下一篇:1019 General Palindromic Number