1025 PAT Ranking (25 分)https://pintia.cn/problem-sets/994805342720868352/problems/994805474338127872
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
程序设计能力测试由浙江大学计算机科学与技术学院组织。每个测试应该在几个地方同时运行,测试之后ranklists将立即合并。现在你的工作就是编写一个程序来正确地合并所有等级列表并生成最终的等级。
输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含一个正数N(≤100),即测试位置的数量。接着是N个等级表,每个等级表从一行开始,其中包含一个正整数K(≤300)、被试人数,然后是K行,其中包含注册号(一个13位数字)和每个被试的总分。一行中的所有数字都用空格隔开。
输出规格:
对于每个测试用例,首先在一行中打印被测试者的总数。然后按以下格式打印最终等级列表:
注册号 最终排名 位置 本地排名
位置的编号从1到N。输出必须按最终秩的不递减顺序排序。具有相同分数的受试者必须具有相同的等级,并且输出必须按照其注册号的不递减顺序进行排序。
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct stu{
string id;
int score,finrank,loca,locarank;
};
bool cmp(stu a,stu b){
return a.score!=b.score?a.score>b.score:a.id<b.id;
}
int main(){
int n,m,sc;
string Id;
scanf("%d",&n);
vector<stu> fin;
for(int i=1;i<=n;i++){
scanf("%d",&m);
vector<stu> v(m);
for(int j=0;j<m;j++){
cin>>v[j].id>>v[j].score;
v[j].loca=i;
}
sort(v.begin(),v.end(),cmp);
v[0].locarank=1;
fin.push_back(v[0]);
for(int j=1;j<v.size();j++){
v[j].locarank=((v[j].score==v[j-1].score)?(v[j-1].locarank):j+1);
fin.push_back(v[j]);
}
}
sort(fin.begin(),fin.end(),cmp);
fin[0].finrank=1;
for(int i=1;i<fin.size();i++){
fin[i].finrank=((fin[i].score==fin[i-1].score)?(fin[i-1].finrank):i+1);
}
cout<<fin.size()<<endl;
for(int i=0;i<fin.size();i++){
cout<<fin[i].id<<" "<<fin[i].finrank<<" "<<fin[i].loca<<" "<<fin[i].locarank<<endl;
}
}