题源:传送门
Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39623 Accepted Submission(s): 28946
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1
2
3
Sample Output
1
10
11
代码:
#include<stdio.h>
int main()
{
int n,i;
int a[25];
while(~scanf("%d",&n))
{
i=0;
while(n)
{
a[i++]=n%2;
n=n/2;
}
while(i--)
printf("%d",a[i]);
printf("\n");
}
return 0;
}