计算机学院大学生程序设计竞赛(2015’12)The Country List

The Country List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2464    Accepted Submission(s): 576

Problem Description
As the 2010 World Expo hosted by Shanghai is coming, CC is very honorable to be a volunteer of such an international pageant. His job is to guide the foreign visitors. Although he has a strong desire to be an excellent volunteer, the lack of English makes him
annoyed for a long time. 

Some countries’ names look so similar that he can’t distinguish them. Such as: Albania and Algeria. If two countries’ names have the same length and there are more than 2 same letters in the same position of each word, CC cannot distinguish them. For example:
Albania and AlgerIa have the same length 7, and their first, second, sixth and seventh letters are same. So CC can’t distinguish them.

Now he has received a name list of countries, please tell him how many words he cannot distinguish. Note that comparisons between letters are case-insensitive.
 
Input
There are multiple test cases.

Each case begins with an integer n (0 < n < 100) indicating the number of countries in the list.

The next n lines each contain a country’s name consisted by ‘a’ ~ ‘z’ or ‘A’ ~ ‘Z’.

Length of each word will not exceed 20.

You can assume that no name will show up twice in the list.
 
Output
For each case, output the number of hard names in CC’s list.
 
Sample Input
3
Denmark
GERMANY
China
4
Aaaa
aBaa
cBaa
cBad
 
Sample Output
2
4
 

总是望着曾经的空间发呆,那些说好不分开的朋友不在了,转身,陌路。 熟悉的,安静了, 安静的,离开了, 离开的,陌生了, 陌生的,消失了, 消失的,陌路了。计算机学院大学生程序设计竞赛(2015’12)The Country List

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int da[105]= {0};
void bijiao(int n,char c[105][30])
{
int i,j,t=0,q;
for(i=0; i<n; i++)
for(j=0; j<n; j++)
{
t=0;
if(strcmp(c[i],c[j])==0)continue;
if(strlen(c[i])==strlen(c[j]))
{
for(q=0; q<(int)strlen(c[i]); q++)
{
if(c[i][q]==c[j][q])t++;
}
if(t>2)
{
da[i]=1;
da[j]=1;
}
}
}
}
void xiaoxie(char c[30])
{
int n=strlen(c),i;
for(i=0; i<n; i++)
{
if(c[i]>='A'&&c[i]<='Z')c[i]+=32;
}
}
int main()
{
int n,i,j;
char c[105][30];
while(~scanf("%d",&n)&&n)
{
j=0;
getchar();
for(i=0; i<n; i++)da[i]=0;
for(i=0; i<n; i++)
{
gets(c[i]);
xiaoxie(c[i]);
}
bijiao(n,c);
for(i=0; i<n; i++)j+=da[i];
printf("%d\n",j);
}
return 0;
}


@执念  "@☆但求“❤”安★
下次我们做的一定会更好。。。。计算机学院大学生程序设计竞赛(2015’12)The Country List




为什么这次的题目是英文的。。。。QAQ...计算机学院大学生程序设计竞赛(2015’12)The Country List

上一篇:HDU 5723 Abandoned country(落后渣国)


下一篇:centos6下安装dedecms