Farmer John and Betsy are playing a game with N (1 <= N <=
30,000)identical cubes labeled 1 through N. They start with N stacks,
each containing a single cube. Farmer John asks Betsy to perform P
(1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
- In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
- In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report
that value.Write a program that can verify the results of the game.
Input
-
Line 1: A single integer, P
-
Lines 2…P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
题目大意:有若干个方块,经p次操作后,在x方块下面的方块有多少个。
M操作—>将包含x方块的堆移到含y方块的堆上
C操作—>输出x方块下方方块的数目
解题思路:以堆最底部的方块作为父节点,dis[a]表示a到父节点的距离,rank[y]表示以y为底部的方块堆的大小,即含有多少个方块,借用find()更新dis。
Code:
#include<iostream>
using namespace std;
int n,x,y,pre[100005],dis[100005],rank[100005];
char ch;//以最底部的为父节点,dis[a]表示a到父节点的距离 ,rank[]表示堆的大小
int find(int x){
if(pre[x]==x) return x;
else {
int r = pre[x];
pre[x]=find(r);
dis[x]+=dis[r];//dis[r] 表示x的父节点到堆底部的大小,dis[x]表示x到父节点的大小
}
return pre[x];
}
void join(int x,int y){
int fx=find(x),fy=find(y);
if(fx!=fy){
pre[fx]=fy;
dis[fx]=rank[fy];
rank[fy]+=rank[fx];
}
}
int main(){
while(cin>>n){
for(int i=1;i<=n;i++) pre[i]=i;
for(int i=1;i<=n;i++) rank[i]=1,dis[i]=0;
for(int i=1;i<=n;i++){
cin>>ch;
if(ch=='M'){
cin>>x>>y;
if(find(x)!=find(y)){
join(x,y);
}
}
else if(ch=='C'){
cin>>x;
find(x);
cout<<dis[x]<<endl;
}
}
}
return 0;
}