[POJ2749]Building roads(2-SAT)

Building roads
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8153   Accepted: 2772

Description

Farmer John's farm has N barns, and there are some cows that live in each barn. The cows like to drop around, so John wants to build some roads to connect these barns. If he builds roads for every pair of different barns, then he must build N * (N - 1) / 2 roads, which is so costly that cheapskate John will never do that, though that's the best choice for the cows.

Clever John just had another good idea. He first builds two
transferring point S1 and S2, and then builds a road connecting S1 and
S2 and N roads connecting each barn with S1 or S2, namely every barn
will connect with S1 or S2, but not both. So that every pair of barns
will be connected by the roads. To make the cows don't spend too much
time while dropping around, John wants to minimize the maximum of
distances between every pair of barns.

That's not the whole story because there is another troublesome
problem. The cows of some barns hate each other, and John can't connect
their barns to the same transferring point. The cows of some barns are
friends with each other, and John must connect their barns to the same
transferring point. What a headache! Now John turns to you for help.
Your task is to find a feasible optimal road-building scheme to make the
maximum of distances between every pair of barns as short as possible,
which means that you must decide which transferring point each barn
should connect to.

We have known the coordinates of S1, S2 and the N barns, the pairs
of barns in which the cows hate each other, and the pairs of barns in
which the cows are friends with each other.

Note that John always builds roads vertically and horizontally, so
the length of road between two places is their Manhattan distance. For
example, saying two points with coordinates (x1, y1) and (x2, y2), the
Manhattan distance between them is |x1 - x2| + |y1 - y2|.

Input

The
first line of input consists of 3 integers N, A and B (2 <= N <=
500, 0 <= A <= 1000, 0 <= B <= 1000), which are the number
of barns, the number of pairs of barns in which the cows hate each other
and the number of pairs of barns in which the cows are friends with
each other.

Next line contains 4 integer sx1, sy1, sx2, sy2, which are the
coordinates of two different transferring point S1 and S2 respectively.

Each of the following N line contains two integer x and y. They are
coordinates of the barns from the first barn to the last one.

Each of the following A lines contains two different integers i and
j(1 <= i < j <= N), which represent the i-th and j-th barns in
which the cows hate each other.

The same pair of barns never appears more than once.

Each of the following B lines contains two different integers i and
j(1 <= i < j <= N), which represent the i-th and j-th barns in
which the cows are friends with each other. The same pair of barns never
appears more than once.

You should note that all the coordinates are in the range [-1000000, 1000000].

Output

You
just need output a line containing a single integer, which represents
the maximum of the distances between every pair of barns, if John
selects the optimal road-building scheme. Note if there is no feasible
solution, just output -1.

Sample Input

4 1 1
12750 28546 15361 32055
6706 3887
10754 8166
12668 19380
15788 16059
3 4
2 3

Sample Output

53246

Source

[Submit]   [Go Back]   [Status]   [Discuss]

考虑二分答案,然后根据题目给出的限制以及这个二分出来的距离限制建图,2-SAT解决。

 #include<cstdio>
#include<cstring>
#include<algorithm>
#define mem(a) memset(a,0,sizeof(a))
#define rep(i,l,r) for (int i=(l); i<=(r); i++)
#define For(i,x) for (int i=h[x],k; i; i=nxt[i])
using namespace std; const int N=,M=N*N*;
int a,b,n,mx,ans,cnt,scc,top,L,R,tim,dis,x1,y1,x2,y2,x,y,dis1[N],dis2[N],ax[N],ay[N],bx[N],by[N];
int to[M],nxt[M],q[N],dfn[N],inq[N],h[N],low[N],bel[N];
void add(int u,int v){ to[++cnt]=v; nxt[cnt]=h[u]; h[u]=cnt; } void init(){ cnt=top=scc=tim=; mem(h); mem(dfn); mem(inq); } int cal(int x1,int y1,int x2,int y2){ return abs(x2-x1)+abs(y2-y1); } void tarjan(int x){
dfn[x]=low[x]=++tim; inq[x]=; q[++top]=x;
For(i,x) if (!dfn[k=to[i]]) tarjan(k),low[x]=min(low[x],low[k]);
else if (inq[k]) low[x]=min(low[x],dfn[k]);
if (dfn[x]==low[x]){
scc++; int t;
do { t=q[top--]; bel[t]=scc; inq[t]=; }while(t!=x);
}
} bool jud(int mid){
init();
rep(i,,n) rep(j,i+,n){
if (dis1[i]+dis1[j]>mid) add(i,n+j),add(j,n+i);
if (dis2[i]+dis2[j]>mid) add(i+n,j),add(j+n,i);
if (dis1[i]+dis2[j]+dis>mid) add(i,j),add(j+n,i+n);
if (dis2[i]+dis1[j]+dis>mid) add(i+n,j+n),add(j,i);
}
rep(i,,a) add(ax[i],ay[i]+n),add(ay[i]+n,ax[i]),add(ay[i],ax[i]+n),add(ax[i]+n,ay[i]);
rep(i,,b) add(bx[i],by[i]),add(by[i],bx[i]),add(bx[i]+n,by[i]+n),add(by[i]+n,bx[i]+n);
rep(i,,*n) if (!dfn[i]) tarjan(i);
rep(i,,n) if (bel[i]==bel[i+n]) return ;
return ;
} int main(){
freopen("poj2749.in","r",stdin);
freopen("poj2749.out","w",stdout);
while (~scanf("%d%d%d",&n,&a,&b)){
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
dis=cal(x1,y1,x2,y2); mx=;
rep(i,,n){
scanf("%d%d",&x,&y);
dis1[i]=cal(x,y,x1,y1); dis2[i]=cal(x,y,x2,y2);
mx=max(mx,max(dis1[i],dis2[i]));
}
mx=mx*+dis;
rep(i,,a) scanf("%d%d",&ax[i],&ay[i]);
rep(i,,b) scanf("%d%d",&bx[i],&by[i]);
int L=,R=mx; ans=-;
while (L<=R){
int mid=(L+R)>>;
if (jud(mid)) ans=mid,R=mid-; else L=mid+;
}
printf("%d\n",ans);
}
return ;
}
上一篇:PHP批量生成手机号


下一篇:centos下mysql 5源码安装全过程记录