HDU1686:Oulipo

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
 
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
 
Sample Output
1
3
0
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int b[];//之前用next[10005]CE,不明确,可能有函数吧。。。,好坑
char ch1[],ch2[];
void get_next(int len1)
{
int i=,j=-;
b[]=-;
while(i<len1)
{
if(j==-||ch1[i]==ch1[j])
{
i++;j++;
if(ch1[i]==ch1[j])
b[i]=b[j];
else
b[i]=j;
}
else
j=b[j];
}
}
int kmp(int len1,int len2)
{
int i=,j=,k=;
get_next(len1);
while(i<len2)
{
if(j==-||ch2[i]==ch1[j])
{i++;j++;}
else
{
j=b[j];
}
if(j==len1)
{
k++;
}
}
return k;
} int main()
{
int n;
cin>>n;
getchar();
while(n--)
{
cin>>ch1>>ch2;
int len1,len2;
len1=strlen(ch1);
len2=strlen(ch2);
get_next(len1);
cout<<kmp(len1,len2)<<endl;
}
return ;
}
上一篇:2018-CVTE*研究院-自然语言处理算法工程师-电话初面问题


下一篇:构建apache web 服务器