Oulipo (kmp)

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26857   Accepted: 10709

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

 #include<cstdio>
#include<cstring>
char t[ + ] , s[ + ] ;
int nxt [ + ] ;
int T ;
int lens , lent ; void PMT ()
{
nxt [] = - ;
for (int i = , j = - ; i < lent ; i++) {
while (j != - && t[i] != t[j + ] ) {
j = nxt[j] ;
}
nxt[i] = t[i] == t[j + ] ? ++ j : j ;
}
} void kmp ()
{
int ret = ;
PMT () ;//partial match table
for (int i = , j = - ; i < lens ; i++) {
while (j != - && s[i] != t[j + ] ) {
j = nxt [j] ;
}
if (s[i] == t[j + ]) {
j ++ ;
if (j == lent - ) {
j = nxt [j] ;
ret ++ ;
}
}
}
printf ("%d\n" , ret );
} int main ()
{
// freopen ("a.txt" , "r" , stdin ) ;
scanf ("%d" , &T) ;
getchar () ;
while (T--) {
memset (nxt , , sizeof(nxt) ) ;
gets (t) ;
gets (s) ;
lens = strlen (s) ;
lent = strlen (t) ;
// puts (t) , puts (s) ;
kmp () ;
}
return ;
}
上一篇:KMP——POJ-3461 Oulipo && POJ-2752 Seek the Name, Seek the Fame && POJ-2406 Power Strings && POJ—1961 Period


下一篇:poj3461 Oulipo (KMP模板题~) 前面哪些也是模板题 O.O