UVA131 HDU1629 The Psychic Poker Player【暴力】

The Psychic Poker Player
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 255 Accepted Submission(s): 49

Problem Description
In 5-card draw poker, a player is dealt a hand of five cards (which may be looked at). The player may then discard between zero and five of his or her cards and have them replaced by the same number of cards from the top of the deck (which is face down). The object is to maximize the value of the final hand. The different values of hands in poker are given at the end of this problem.

Normally the player cannot see the cards in the deck and so must use probability to decide which cards to discard. In this problem, we imagine that the poker player is psychic and knows which cards are on top of the deck. Write a program which advises the player which cards to discard so as to maximize the value of the resulting hand.

Input
Input will consist of a series of lines, each containing the initial five cards in the hand then the first five cards on top of the deck. Each card is represented as a two-character code. The first character is the face-value (A=Ace, 2-9, T=10, J=Jack, Q=Queen, K=King) and the second character is the suit (C=Clubs, D=Diamonds, H=Hearts, S=Spades). Cards will be separated by single spaces. Each input line will be from a single valid deck, that is there will be no duplicate cards in each hand and deck.

Each line of input should produce one line of output, consisting of the initial hand, the top five cards on the deck, and the best value of hand that is possible. Input is terminated by end of file.

Use the sample input and output as a guide. Note that the order of the cards in the player's hand is irrelevant, but the order of the cards in the deck is important because the discarded cards must be replaced from the top of the deck. Also note that examples of all types of hands appear in the sample output, with the hands shown in decreasing order of value.

Sample Input
TH JH QC QD QS QH KH AH 2S 6S
2H 2S 3H 3S 3C 2D 3D 6C 9C TH
2H 2S 3H 3S 3C 2D 9C 3D 6C TH
2H AD 5H AC 7H AH 6H 9H 4H 3C
AC 2D 9C 3S KD 5S 4D KS AS 4C
KS AH 2H 3C 4H KC 2C TC 2D AS
AH 2C 9S AD 3C QH KS JS JD KD
6C 9C 8C 2D 7C 2H TC 4C 9S AH
3D 5S 2H QD TD 6S KH 9H AD QH

Sample Output
Hand: TH JH QC QD QS Deck: QH KH AH 2S 6S Best hand: straight-flush
Hand: 2H 2S 3H 3S 3C Deck: 2D 3D 6C 9C TH Best hand: four-of-a-kind
Hand: 2H 2S 3H 3S 3C Deck: 2D 9C 3D 6C TH Best hand: full-house
Hand: 2H AD 5H AC 7H Deck: AH 6H 9H 4H 3C Best hand: flush
Hand: AC 2D 9C 3S KD Deck: 5S 4D KS AS 4C Best hand: straight
Hand: KS AH 2H 3C 4H Deck: KC 2C TC 2D AS Best hand: three-of-a-kind
Hand: AH 2C 9S AD 3C Deck: QH KS JS JD KD Best hand: two-pairs
Hand: 6C 9C 8C 2D 7C Deck: 2H TC 4C 9S AH Best hand: one-pair
Hand: 3D 5S 2H QD TD Deck: 6S KH 9H AD QH Best hand: highest-card

Source
uva

问题链接UVA131 HDU1629 The Psychic Poker Player
问题简述:(略)
问题分析
    德州扑克牌问题,判定手牌最佳的牌。
    10张牌中任意取5张,从中找出最佳牌点。
straight-flush  同花顺
four-of-a-kind   炸弹
full-house    满堂红(三张同点牌加上一对)
flush     同花
straight    顺子(注意A即可接2也可以接K)
three-of-a-kind 三张相同的牌
two-pairs    两对对子
one-pair    一对对子
highest-card 单张最大
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++程序如下:

/* UVA131 HDU1629 The Psychic Poker Player */

#include <bits/stdc++.h>

using namespace std;

const int N = 10;
const int M = 5;
string s[N], a[M];
string bh[] = {     // Best Hand
     "straight-flush"
    , "four-of-a-kind"
    , "full-house"
    , "flush"
    , "straight"
    , "three-of-a-kind"
    , "two-pairs"
    , "one-pair"
    , "highest-card"
};

int b[5], c[5];

int convert[128];
void init()
{
    for(int i = 2; i <= 9; i++)
        convert['0' + i] = i;
    convert['T'] = 10;
    convert['J'] = 11;
    convert['Q'] = 12;
    convert['K'] = 13;
    convert['A'] = 14;

    convert['C'] = 1;       // 梅花
    convert['D'] = 2;       // 方片
    convert['H'] = 3;       // 红桃
    convert['S'] = 4;       // 黑桃
}

int solve()
{
    int flush, straight, i, j;        // 同花:flush,顺子:straight

    for (i = 0; i < M; i++) {
        b[i] = convert[(int)a[i][0]];
        c[i] = convert[(int)a[i][1]];
    }

    // 整理牌:排序
    for (i = 0; i < M - 1; i++)
        for (j = i + 1; j < M; j++)
            if (b[i] > b[j]) {
                swap(b[i], b[j]);
                swap(c[i], c[j]);
            } else if (b[i] == b[j] && c[i] > c[j])
                swap(c[i], c[j]);

    // 判定同花
    for (flush = 1, i = 0; i < M - 1; i++)
        if (c[i] != c[i + 1]) {
            flush = 0;
            break;
        }

    // 判定顺子
    for (straight = 1, i = 0; i < M - 1; i++)
        if (b[i] + 1 != b[i + 1]) {
            if (i == 3 && b[i + 1] == 14 && b[0] == 2)
                ;
            else {
                straight = 0;
                break;
            }
        }

    if (flush && straight) return 0;
    if (b[1] == b[3] && (b[1] == b[0] || b[3] == b[4])) return 1;
    if (b[0] == b[1] && b[2] == b[4]) return 2;
    if (b[0] == b[2] && b[3] == b[4]) return 2;
    if (flush) return 3;
    if (straight) return 4;
    if (b[0] == b[2] || b[1] == b[3] || b[2] == b[4]) return 5;
    if (b[0] == b[1] && (b[2] == b[3] || b[3] == b[4])) return 6;
    if (b[1] == b[2] && b[3] == b[4]) return 6;
    if (b[0] == b[1] || b[1] == b[2] || b[2] == b[3] || b[3] == b[4]) return 7;
    return 8;
}

int main()
{
    init();

    int ans, i, j, k;
    while (cin >> s[0]) {
        for (i = 1; i < N; i++)
            cin >> s[i];

        // 暴力搜索:10中取5处理,2^5=32
        for (ans = 8, i = 0; i < 32; i++) {
            for (j = 0, k = 0; j < M; j++)
                if (((i >> j) & 1) == 1) a[k++] = s[j];
            for (j = M; j < N && k < M; j++) a[k++] = s[j];
            ans = min(ans, solve());
        }

        // 输出结果
        cout << "Hand: " ;
        for (i = 0; i < M; i++) cout << s[i] << " ";
        cout << "Deck: " ;
        for (i = M; i < N; i++) cout << s[i] << " ";
        cout << "Best hand: " << bh[ans] << endl;
    }

    return 0;
}
上一篇:3.8 51单片机-M74HC138译码器驱动8位数码管


下一篇:Sqoop2环境搭建