POJ 2386 Lake Counting

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has. 

Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them. 

Output
* Line 1: The number of ponds in Farmer John’s field.
Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side. 

AC代码:

//poj-2386-Lake counting(八连通)
#include<iostream>
#include<cstdio>
using namespace std;
#define N 100
int n,m;
char map[N][N];
void dfs(int x,int y){
	map[x][y]='.';
	for(int dx=-1;dx<=1;dx++)
		for(int dy=-1;dy<=1;dy++)
		{
			int nx=dx+x;
			int ny=dy+y;
			if(nx>=0&&nx<n&&ny>=0&&ny<m&&map[nx][ny]=='W') 
				dfs(nx,ny);
		}
	return;
}
int main(){
	scanf("%d%d",&n,&m);
	int ans=0;
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	cin>>map[i][j];
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	{
		if(map[i][j]=='W'){
			dfs(i,j);
			ans++; //遍历一遍,计算加一
		}
	}
	printf("%d\n",ans);
	return 0;
}
上一篇:Markdown插入图表


下一篇:groovy基本语法--JSON