题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1686
分析:典型的KMP算法,统计字符串匹配的次数。 用Next数组压缩时间复杂度,要做一些修改。
/*Oulipo Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5769 Accepted Submission(s): 2322 Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN Sample Output
1
3
0
*/
//KMP
#include <cstdio>
#include <cstring>
const int maxn = + , maxm = + ;
int next[maxn], len1, len2;
char a[maxn], b[maxm];
void getNext()
{
int i, j = , k = -;
next[] = -;
while(j < len1){
if(k == - || a[j] == a[k]) next[++j] = ++k;
else k = next[k];
}
}
int kmp()
{
int i = , j = , ans = ;
while(i < len2){
while(j != - && b[i] != a[j]) j = next[j];
i++; j++;
if(j >= len1){
ans++;
j = next[j];
}
}
return ans;
}
int main()
{
int T;
scanf("%d", &T);
while(T--){
scanf("%s%s", a, b);
len1 = strlen(a); len2 = strlen(b);
getNext();
printf("%d\n", kmp());
}
return ;
}