1044 Shopping in Mars (25 分)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains Npositive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

分析:一开始直接模拟发现测试点2和5超时了,解决办法:sum是严格递增的,所以可以用二分来加速。。不过这题的二分好难写,注意下标位置

原始代码:
 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-26-15.17.46
 * Description : A1044
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;
 ;
 ;
 int a[maxn];
 int n,S,nearS=INF;
 struct Node{
     int l,r;
 };
 vector<Node> ans;
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     int n,m;
     scanf("%d%d",&n,&m);
     ;i<=n;i++){
         scanf("%d",&a[i]);
     }
     int sum,i,j;
     ;i<=n;i++){
         sum=;
         for(j=i;j<=n;j++){
             sum+=a[j];
             if(sum>=m){
                 if(nearS>sum){
                     ans.clear();
                     nearS=sum;
                     ans.push_back(Node{i,j});
                 }
                 else if(nearS==sum){
                     ans.push_back(Node{i,j});
                 }
                 break;
             }
         }
     }
     ;i<ans.size();i++){
         printf("%d-%d\n",ans[i].l,ans[i].r);
     }
     ;
 }

1044 Shopping in Mars (25 分)

二分:

 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-26-15.17.46
 * Description : A1044
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;
 ;
 ;
 int sum[maxn],nearS=INF;
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     int n,m;
     scanf("%d%d",&n,&m);
     sum[]=;
     ;i<=n;i++){
         scanf("%d",&sum[i]);
         sum[i]+=sum[i-];
     }
     ;i<=n;i++){
         ,sum[i-]+m)-sum;
         ]-sum[i-]==m){
             nearS=m;
             break;
         }
         ]<nearS){
             nearS=sum[j]-sum[i-];
         }
     }
     ;i<=n;i++){
         ,sum[i-]+nearS)-sum;
         ]-sum[i-]==nearS){
             printf();
         }
     }
     ;
 }

自定义二分。。

 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-26-15.17.46
 * Description : A1044
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;
 ;
 ;
 int sum[maxn],nearS=INF;
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     int n,m;
     scanf("%d%d",&n,&m);
     sum[]=;
     ;i<=n;i++){
         scanf("%d",&sum[i]);
         sum[i]+=sum[i-];
     }
     ;i<=n;i++){
         ,sum[i-]+m)-sum;
         ]-sum[i-]==m){
             nearS=m;
             break;
         }
         ]<nearS){
             nearS=sum[j]-sum[i-];
         }
     }
     ;i<=n;i++){
         ,sum[i-]+nearS)-sum;
         ]-sum[i-]==nearS){
             printf();
         }
     }
     ;
 }

1044 Shopping in Mars (25 分)



上一篇:TF-IDF 简介


下一篇:POJ 1661 Help Jimmy DP