zoj1797 Least Common Multiple 最小公倍数

Least Common Multiple


Time Limit:
2 Seconds      Memory Limit:
65536 KB
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm
where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1

Sample Output

105

10296

简单gcd,拿出来的唯一原因是::注意int是否会超。

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<iostream>
using namespace std;
int _gcd(int a,int b)
{
if(b==0) return a;
return _gcd(b,a%b);
}
int _solve(int v,int u)
{
int m=_gcd(u,v);
return u/m*v;//这里一定要先除,不然会超。。。。。qwq
}
int main()
{
int T,n,ans,x;
cin>>T;
while(T--)
{
cin>>n;
cin>>ans;
for(int i=2;i<=n;i++)
{
cin>>x;
ans=_solve(ans,x);
}
cout<<ans<<endl;
} return 0;
}

上一篇:Ubuntu系统下在github中新增库的方法


下一篇:BZOJ 1305--[CQOI2009]dance跳舞(最大流)