As Christmas is around the corner, Boys are busy in choosing
christmas presents to send to their girlfriends. It is believed that
chain bracelet is a good choice. However, Things are not always so
simple, as is known to everyone, girl's fond of the colorful decoration
to make bracelet appears vivid and lively, meanwhile they want to
display their mature side as college students. after CC understands the
girls demands, he intends to sell the chain bracelet called
CharmBracelet. The CharmBracelet is made up with colorful pearls to show
girls' lively, and the most important thing is that it must be
connected by a cyclic chain which means the color of pearls are cyclic
connected from the left to right. And the cyclic count must be more than
one. If you connect the leftmost pearl and the rightmost pearl of such
chain, you can make a CharmBracelet. Just like the pictrue below, this
CharmBracelet's cycle is 9 and its cyclic count is 2:
Now CC has brought in some ordinary bracelet chains, he wants to
buy minimum number of pearls to make CharmBracelets so that he can save
more money. but when remaking the bracelet, he can only add color pearls
to the left end and right end of the chain, that is to say, adding to
the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Each test case contains only one line describe the original ordinary
chain to be remade. Each character in the string stands for one pearl
and there are 26 kinds of pearls being described by 'a' ~'z' characters.
The length of the string Len: ( 3 <= Len <= 100000 ).OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet.Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5 kmp求循环节。
推荐博客:https://www.cnblogs.com/chenxiwenruo/p/3546457.html
注意题目要求至少循环两次。所以判断条件需要写出来
#include<stdio.h>
#include<string.h>
int n,Next[],T,plen;
char p[]; void prekmp() {
plen=strlen(p);
int i,j;
j=Next[]=-;
i=;
while(i<plen) {
while(j!=-&&p[i]!=p[j]) j=Next[j];
if(p[++i]==p[++j]) Next[i]=Next[j];
else Next[i]=j;
}
} int main() {
//freopen("out","r",stdin);
scanf("%d",&T);
while(T--) {
scanf("%s",p);
prekmp();
//printf("%d**\n",Next[plen]);
int l=plen-Next[plen];
if(plen%l==&&plen/l>) printf("0\n");
else printf("%d\n",l-plen%l);
}
}