ACM: 限时训练题解-Street Lamps-贪心-字符串【超水】

  1. Street Lamps

 

Bahosain is walking in a street of N blocks. Each block is either empty or has one lamp. If there is a lamp in a block, it will light it’s block and the direct adjacent blocks. For example, if there is a lamp at block 3, it will light the blocks 2, 3, and 4.

Given the state of the street, determine the minimum number of lamps to be installed such that each block is lit.

Input

 

The first line of input contains an integer T (1 ≤ T ≤   1025) that represents the number of test cases.

The first line of each test case contains one integer N (1 ≤ N ≤ 100) that represents the number of blocks in the street.

The next line contains N characters, each is either a dot ’.’ or an asterisk   ’*’.

A dot represents an empty block, while an asterisk represents a block with a lamp installed in it.

Output

 

For each test case, print a single line with the minimum number of lamps that have to be installed so that all blocks are lit.

Sample Input

Sample Output

3

2

6

0

......

1

3

*.*

8

.*.....*

/*
这题纯水。
*/ #include"iostream"
#include"algorithm"
#include"cstdio"
#include"cstring"
#include"cmath"
#define MX 100 + 5
using namespace std; char s[MX];
bool ss[MX]; int main() {
int T,ans,len;
scanf("%d",&T);
while(T--) {
memset(ss,0,sizeof(ss));
memset(s,0,sizeof(s));
scanf("%d%s",&len,s+1);
ans=0;
for(int i=1; i<=len; i++) {
if(s[i]=='*') {
ss[i-1]=ss[i]=ss[i+1]=1; //把已经照亮的地方标记为 1
}
}
int tot=0;
for(int i=1; i<=len; i++) {
if(ss[i]) { //统计每一个没亮的地方的长度
ans+=(tot+2)/3; //除3 向上取整
tot=0;
}
else tot++;
}
ans+=(tot+2)/3;
printf("%d\n",ans);
}
return 0;
}

  

上一篇:申请邓白氏编码的时候总是提示 Enter a valid Street Address 怎么办?


下一篇:[BZOJ5109]大吉大利,晚上吃鸡!