HDU OJ Digital Roots 题目1013



/*Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 58506    Accepted Submission(s): 18275

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24

39

0

Sample Output

6

3

Source

Greater New York 2000 

Recommend

We have carefully selected several similar problems for you:  1008 1017 1012 1018 1005 #include<stdio.h>

*/越简单越小心  数字与字符之间的转换

#include<string.h>

int ji(int n)

{

 int sum=0;

 while(n!=0)

 {

  sum+=n%10;

  n=n/10;

 }

 if(sum/10!=0) ji(sum);

 else return sum;

}

int main()

{

 char s[1001];

 int m;

 while(scanf("%s",s),s[0]!='0')

    {

     int n=0,k;

     k=strlen(s);

     for(int i=0;i<k;i++)

       n+=s[i]-'0';

  printf("%d\n",ji(n));

    }

    return 0;

}

上一篇:如何优雅地使用 VSCode 来编辑 vue 文件?


下一篇:Python 列表表达式 ,迭代器(1)