#1155. Heap Paths【完全二叉树 + 堆 + DFS】

原题链接

Problem Description:

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N N N ( 1 < N ≤ 1 , 000 1< N\leq 1,000 1<N≤1,000), the number of keys in the tree. Then the next line contains N N N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

Problem Analysis:

由于完全二叉树是以层序遍历的方式给出的,因此直接遍历一遍即可完成建树操作。

观察所给样例可以看出,需要我们按照根-右-左的方式进行遍历这个堆,如果当前点为叶子节点,就输出整个答案序列。

void dfs(int u) 
{
    ans[cnt ++ ] = w[u];

    if (!l[u] && !r[u]) 
    {
        for (int i = 0; i < cnt; i ++ ) 
        {
            printf("%d", ans[i]);
            if (i != cnt - 1) printf(" ");
        }
        puts("");
        return;
    }
    if (r[u]) dfs(r[u]), -- cnt; // 恢复现场
    if (l[u]) dfs(l[u]), -- cnt;
}

Code

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <unordered_map>

using namespace std;

const int N = 1e4 + 10;

int n;
unordered_map<int, int> l, r;
int w[N];
int ans[N], cnt;

int check(int w[]) // 大 / 小 / 非根堆的判断
{
    bool flag = true;
    for (int i = 1; i <= n; i ++ )
        if ((i << 1) <= n && w[i << 1] > w[i]) 
        {
            flag = false;
            break;
        }
        else if ((i << 1 | 1) <= n && w[i << 1 | 1] > w[i])
        {
            flag = false;
            break;
        }
    
    if (flag) return 1;
    flag = true;
    for (int i = 1; i <= n; i ++ )
        if ((i << 1) <= n && w[i << 1] < w[i]) 
        {
            flag = false;
            break;
        }
        else if ((i << 1 | 1) <= n && w[i << 1 | 1] < w[i])
        {
            flag = false;
            break;
        }
    if (flag) return -1;
    return 0;
}

void dfs(int u) 
{
    ans[cnt ++ ] = w[u];

    if (!l[u] && !r[u]) 
    {
        for (int i = 0; i < cnt; i ++ ) 
        {
            printf("%d", ans[i]);
            if (i != cnt - 1) printf(" ");
        }
        puts("");
        return;
    }
    if (r[u]) dfs(r[u]), -- cnt; // 恢复现场
    if (l[u]) dfs(l[u]), -- cnt;
}

int main()
{
    cin >> n;
    for (int i = 1; i <= n; i ++ ) // 读入权值并建树
    {
        scanf("%d", &w[i]);
        if ((i << 1) <= n) l[i] = i << 1;
        if ((i << 1 | 1) <= n) r[i] = i << 1 | 1;
    }

    int flag = check(w);
    dfs(1);

    if (flag == 1) puts("Max Heap");
    else if (flag == -1) puts("Min Heap");
    else puts("Not Heap");
    
    return 0;
}
上一篇:c++哈希堆的实现


下一篇:标准模板库巧解算法题 优先队列