黑龙江省第七届大学生程序设计竞赛-Mysterious Organization

描述

GFW had intercepted billions of illegal links successfully. It has much more effect. Today, GFW intercepted a message of a mysterious organization. This mysterious organization package the message in legitimate URL.
To find the Black Hand behind the scenes, GFW didn’t shield the IP. Instead, it chooses to tap the massage. Because the messages are packaged in URL, and encrypted by the way we don’t know, GFW chooses to monitor all the URL passed, to get enough information to find the Black Hand behind the scenes.
This kind of URL is easy to find. This kind of URL including the word’ manure’. Your task is to find how many URL is this kind.

输入

Input has only one case, it has multiple lines. Each line has a string standing for the URL passing GFW. The length of the string is less than 256 without blank in it. There won’t be more than 256 lines in the cases.

输出

Output one line standing for the number of URL GFW needs.

样例输入

https://61.135.169.105//manurer//whoistheboss
http://61.135.169.105//manur//whoistheboss
http://61.135.169.105//mare//whoistheboss
https://61.135.169.105//manure//Iamtheboss

样例输出

2

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
char a[300];
int sum=0;
while(cin>>a)
{ for(int i=0;i<strlen(a)-5;i++)
{
if(a[i]=='m'&&a[i+1]=='a'&&a[i+2]=='n'&&a[i+3]=='u'&&a[i+4]=='r'&&a[i+5]=='e')
sum++;
}
}
cout<<sum<<endl;
return 0;
}
上一篇:MVC过滤器使用案例:统一处理异常顺道精简代码


下一篇:Android开发--TextView的应用