奇数码
你一定玩过八数码游戏,它实际上是在一个 3×3 的网格中进行的,1 个空格和 1∼8 这 8 个数字恰好不重不漏地分布在这 3×3 的网格中。
例如:
5 2 8
1 3 _
4 6 7
在游戏过程中,可以把空格与其上、下、左、右四个方向之一的数字交换(如果存在)。
例如在上例中,空格可与左、上、下面的数字交换,分别变成:
5 2 8 5 2 _ 5 2 8
1 _ 3 1 3 8 1 3 7
4 6 7 4 6 7 4 6 _
奇数码游戏是它的一个扩展,在一个 n×n 的网格中进行,其中 n 为奇数,1 个空格和 1∼n2−1 这 n2−1 个数恰好不重不漏地分布在 n×n 的网格中。
空格移动的规则与八数码游戏相同,实际上,八数码就是一个 n=3 的奇数码游戏。
现在给定两个奇数码游戏的局面,请判断是否存在一种移动空格的方式,使得其中一个局面可以变化到另一个局面。
输入格式
多组数据,对于每组数据:
第 1 行输入一个整数 n,n 为奇数。
接下来 n 行每行 n 个整数,表示第一个局面。
再接下来 n 行每行 n 个整数,表示第二个局面。
局面中每个整数都是 0∼n2−1 之一,其中用 0 代表空格,其余数值与奇数码游戏中的意义相同,保证这些整数的分布不重不漏。
输出格式
对于每组数据,若两个局面可达,输出 TAK,否则输出 NIE。
数据范围
1≤n<500
输入样例:
3
1 2 3
0 4 6
7 5 8
1 2 3
4 5 6
7 8 0
1
0
0
输出样例:
TAK
TAK
算法:归并排序
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int N = 250000;
int c[N], temp[N];
LL merge_sort(int l, int r, int a[])
{
if(l >= r) return 0;
int mid = l + r >> 1, i = l, j = mid + 1, k = 0;
LL res = merge_sort(l, mid, a) + merge_sort(mid + 1, r, a);
while(i <= mid && j <= r)
{
if(a[i] <= a[j]) temp[k++] = a[i++];
else
{
res += mid - i + 1;
temp[k++] = a[j++];
}
}
while(i <= mid) temp[k++] = a[i++];
while(j <= r) temp[k++] = a[j++];
for(int i = l, j = 0; i <= r; i++, j++) a[i] = temp[j];
return res;
}
int main()
{
int n;
while(cin >> n && n)
{
int a[N], b[N];
for(int i = 0, j = 0; i < n * n; i++)
{
cin >> c[i];
if(c[i]) a[j++] = c[i];
}
for(int i = 0, j = 0; i < n * n; i++)
{
cin >> c[i];
if(c[i]) b[j++] = c[i];
}
LL res1 = merge_sort(0, n * n - 1, a);
memset(temp, 0, sizeof temp);
LL res2 = merge_sort(0, n * n - 1, b);
memset(temp, 0, sizeof temp);
if((res1 % 2) == (res2 % 2)) puts("TAK");
else puts("NIE");
}
return 0;
}