(find) nyoj5-Binary String Matching

5-Binary String Matching

内存限制:64MB 时间限制:3000ms 特判: No
通过数:232 提交数:458 难度:3

题目描述:

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入描述:

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出描述:

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入:

复制
3
11
1001110110
101
110010010010001
1010
110100010101011

样例输出:

3
0
3 可以用find。
注意用getchar()。。。。。。。
C++代码:
#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
using namespace std;
int main(){
int T;
scanf("%d",&T);
getchar(); //必须加上
while(T--){
string s1;
string s2;
getline(cin,s1);
getline(cin,s2);
int ans = s2.find(s1,);
int num = ;
while(ans >= ){
num++;
ans = s2.find(s1,ans+);
}
printf("%d\n",num);
}
return ;
}
上一篇:vue使用国际化


下一篇:c# 正则表达式取值、替换