Can you solve this equation?(二分)

Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 61   Accepted Submission(s) : 37
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 
Sample Input
2 100 -4
 
Sample Output
1.6152 No solution!
 
题解:二分法
代码:
 #include<stdio.h>
double abs(double x){
return x>?x:-x;
}
double operate(double x){
return *x*x*x*x+*x*x*x+*x*x+*x+6.0;
}
double search(double y){
double l=,r=,mid;
while(r-l>1e-){mid=(l+r)/;
if(operate(mid)<y)l=mid;
else r=mid;
if(abs(operate(mid)-y)<1e-)break;
}
return mid;
}
int main(){
int T;
double Y;
scanf("%d",&T);
while(T--){
scanf("%lf",&Y);
if(Y<operate()||Y>operate())puts("No solution!");
else printf("%.4lf\n",search(Y));
}
return ;
}
上一篇:【ElasticSearch】ElasticSearch-索引优化-自定义索引


下一篇:HDU 3639 Hawk-and-Chicken (强连通缩点+DFS)