九度oj 1464 Hello World for U 2012年浙江大学计算机及软件工程研究生机试真题

题目1464:Hello World for U

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:3872

解决:1082

题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com
样例输出:
h   !
e d
l l
lowor
a m
c o
. c
jobdu.
来源:
2012年浙江大学计算机及软件工程研究生机试真题
分析:
 #include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
string s;
int n1,n3;
while(cin>>s){
int len=s.length()-;
int n=len+;
int nn=n+;
while(nn%){
nn--;
}
n1=nn/;
//cout<<n1<<endl;
n3=n-n1*+;
int i=;
//cout<<n3<<endl;
for(;i<n1-;i++){
cout<<s[i];
int j=;
for(;j<n3-;j++){
cout<<" "; }
cout<<s[len-i]<<endl;
}
int k=i+n3;
for(;i<k;i++){
cout<<s[i];
}
cout<<endl;
}
return ;
}
上一篇:从0到1学习node(七)之express搭建简易论坛


下一篇:Win10下使用MinGW到指定路径编译C-C++文件