c++:求阶乘

题目描述

给出一个n,计算n的阶乘。

n!=1*2*3*……*n。

规定:0!=1

输入

一个数n。

输出

一个数表示n的阶乘。

样例输入 Copy

3

样例输出 Copy

6

提示

0<=n<=20

注意阶乘的大小

#include <bits/stdc++.h>
using namespace std;
  
int main()
{
    unsigned int n;
    unsigned long long factorial = 1;
  
    cin >> n;
  
    for(int i = 1; i <=n; ++i)
    {
        factorial *= i;
    }
  
    cout << factorial;    
    return 0;
}

 

上一篇:合并石子 (不是你想象的那个合并石子


下一篇:c深刨关键字3——彻底搞明白整型在内存的存储!