hdu 5159 Card (期望)

Problem Description
There are x cards on the desk, they are numbered from 1 to x. The score of the card which is numbered i(1<=i<=x) is i. Every round BieBie picks one card out of the x cards,then puts it back. He does the same operation for b rounds. Assume that the score of the j-th card he picks is Sj . You are expected to calculate the expectation of the sum of the different score he picks.
 
Input
Multi test cases,the first line of the input is a number T which indicates the number of test cases.  In the next T lines, every line contain x,b separated by exactly one space.
[Technique specification] All numbers are integers. 1<=T<=500000 1<=x<=100000 1<=b<=5
 
Output
Each case occupies one line. The output format is Case #id: ans, here id is the data number which starts from 1,ans is the expectation, accurate to 3 decimal places. See the sample for more details.
 
Sample Input
2
2 3
3 3
 
Sample Output
Case #1: 2.625
Case #2: 4.222
Hint

For the first case, all possible combinations BieBie can pick are (1, 1, 1),(1,1,2),(1,2,1),(1,2,2),(2,1,1),(2,1,2),(2,2,1),(2,2,2)
For (1,1,1),there is only one kind number i.e. 1, so the sum of different score is 1.
However, for (1,2,1), there are two kind numbers i.e. 1 and 2, so the sum of different score is 1+2=3.
So the sums of different score to corresponding combination are 1,3,3,3,3,3,3,2
So the expectation is (1+3+3+3+3+3+3+2)/8=2.625

 
Source
 
题意:
桌子上有a张牌,每张牌从1到a编号,编号为i(1<=i<=a)的牌上面标记着分数i , 每次从这a张牌中随机抽出一张牌,然后放回,执行b次操作,记第j次取出的牌上面分数是 Sj, 问b次操作后不同种类分数之和的期望是多少。
思路:
设Xi代表分数为i的牌在b次操作中是否被选到,Xi=1为选到,Xi=0为未选到
那么期望EX=1*X1+2*X2+3*X3+…+x*Xx
Xi在b次中被选到的概率是1-(1-1/x)^b
那么E(Xi)= 1-(1-1/x)^b
那么EX=1*E(X1)+2*E(X2)+3*E(X3)+…+x*E(Xx)=(1+x)*x/2*(1-(1-1/x)^b)
 #include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
double x,b;
int ac=;
while(t--)
{
scanf("%lf%lf",&x,&b);
double ans=;
double p=-pow((-1.0/x),b);
double num=(+x)*x*1.0/;
ans=num*p;
printf("Case #%d: ",++ac);
printf("%.3lf\n",ans);
}
return ;
}
 
上一篇:Linux场景下的辅助命令操作汇总


下一篇:分享PowerDesigner使用的设置