描述
给定年月,打印当月的月历表。
输入
输入为一行两个整数,第一个整数是年份year(1900 ≤ year ≤ 2099),第二个整数是月份month(1 ≤ month ≤ 12),中间用单个空格隔开。
输出
输出为月历表。月历表第一行为星期表头,如下所示:
Sun Mon Tue Wed Thu Fri Sat
其余各行一次是当月各天的日期,从1日开始到31日(30日或28日)。
日期数字应于星期表头右对齐,即各位数与星期表头相应缩写的最后一个字母对齐。日期中间用空格分隔出空白。
样例输入
2006 5
样例输出
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31
提示
闰年判断方法:能被4整除但不能被100整除,或者能被400整除。
1900年1月1日是周一。
#include<iostream>
using namespace std;
int fun(int year,int month);
bool leapyear(int i);
int main()
{
int year,month;
int week=1;
cin>>year>>month;
fun( year, month);
for (int i = 1900; i < year; ++i)//得到所在年份星期
{
week=((leapyear(i)?366:365)+week)%7;
}
//cout<<week<<"!!!"<<endl;
for (int i = 1; i < month; ++i) //得到所在月份星期
{
week=(fun(year,i)+week)%7;
}
//cout<<week<<"!"<<endl;
cout<<"Sun Mon Tue Wed Thu Fri Sat"<<endl;
for(int i=0;i<week;++i)
{
cout<<" ";//4个空格,一个字符等于4个int
}
int day=fun(year,month);
//cout<<day<<"!!!"<<endl;
for (int j = 1; j <= day ; ++j)
{
if((j-1+week)%7==0)//输出换行
{
cout<<endl;
}
printf("%3d ",j);
}
return 0;
}
bool leapyear(int i)//判断闰年
{
if((i%4==0&&i%100!=0)||(i%400==0))
{
return true;
}
else
{
return false;
}
}
int fun(int year,int month)//得到天数
{
switch(month)
{
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:return 31;break;
case 2: if(leapyear(year)==1)
{return 29;}
else return 28;break;
case 4:
case 6:
case 9:
case 11:return 30;break;
}
}