A. Dense Array
T组测试样例,每组n个数据,问最少需要在当前这组数据中插入多少个数使得当前的这组数据满足相邻两个数据之间的最大值与最小值的比值小于等于2。
输入样例
6
4
4 2 10 1
2
1 3
2
6 1
3
1 4 2
5
1 2 3 4 3
12
4 31 25 50 30 20 34 46 42 16 15 16
输出样例
5
1
2
1
0
3
解题思路
在每次读入数据的时候进行分析
首先如果最大值小于最小值的两倍,直接读入
否则就判定一下谁大谁小,以决定我们加的数是变大还是变小
这里选择了ceil函数,可以更简单的解决问题
AC代码
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
const int N=51;
int a[N];
using namespace std;
int main()
{
int t;
cin>>t;
while(t--)
{
int n;
cin>>n;
cin>>a[1];
int count=0;
for(int i=2;i<=n;i++)
{
int x;
cin>>x;
if(max(x,a[i-1])<=2*min(x,a[i-1]))
a[i]=x;
else
{
double cx=a[i-1];
if(x>a[i-1])
{
while(cx*2<x)
{
count++;
cx*=2;
}
}
else
{
while(ceil(cx/2)>x)
{
count++;
cx=ceil(cx/2);
}
}
}
a[i]=x;
}
cout<<count<<endl;
}
}