hdu2004 成绩转换【C++】

成绩转换

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 173950    Accepted Submission(s): 76178

Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
 
Input
输入数据有多组,每组占一行,由一个整数组成。
 
Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
 
Sample Input
56
67
100
123
 
Sample Output
E
D
A
Score is error!
 #include<cstdio>
using namespace std;
int main()
{
int x;
while(scanf("%d",&x)!=EOF)
{
if(x>= && x <=)
{
printf("A\n");
}
else if(x>= && x <=)
{
printf("B\n");
}
else if(x>= && x <=)
{
printf("C\n");
}
else if(x>= && x <=)
{
printf("D\n");
}
else if(x>= && x <=)
{
printf("E\n");
}
else
{
printf("Score is error!\n");
}
}
return ;
}
上一篇:OpenCV配置使用版


下一篇:pycharm+gitee