1068 万绿丛中一点红 (20 分)测试点3、5

1068 万绿丛中一点红 (20 分)

对于计算机而言,颜色不过是像素点对应的一个 24 位的数值。现给定一幅分辨率为 M×N 的画,要求你找出万绿丛中的一点红,即有独一无二颜色的那个像素点,并且该点的颜色与其周围 8 个相邻像素的颜色差充分大。

输入格式:
输入第一行给出三个正整数,分别是 M 和 N(≤ 1000),即图像的分辨率;以及 TOL,是所求像素点与相邻点的颜色差阈值,色差超过 TOL 的点才被考虑。随后 N 行,每行给出 M 个像素的颜色值,范围在 [0,2^​24​​ ) 内。所有同行数字间用空格或 TAB 分开。

输出格式:
在一行中按照 (x, y): color 的格式输出所求像素点的位置以及颜色值,其中位置 x 和 y 分别是该像素在图像矩阵中的列、行编号(从 1 开始编号)。如果这样的点不唯一,则输出 Not Unique;如果这样的点不存在,则输出 Not Exist。

输入样例 1:
8 6 200
0 0 0 0 0 0 0 0
65280 65280 65280 16711479 65280 65280 65280 65280
16711479 65280 65280 65280 16711680 65280 65280 65280
65280 65280 65280 65280 65280 65280 165280 165280
65280 65280 16777015 65280 65280 165280 65480 165280
16777215 16777215 16777215 16777215 16777215 16777215 16777215 16777215
输出样例 1:
(5, 3): 16711680
输入样例 2:
4 5 2
0 0 0 0
0 0 3 0
0 0 0 0
0 5 0 0
0 0 0 0
输出样例 2:
Not Unique
输入样例 3:
3 3 5
1 2 3
3 4 5
5 6 7
输出样例 3:
Not Exist

代码如下:

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<iostream>

using namespace std;

const int max_n = 1006;

struct candiate
{
    int x, y;
}temp;

int picture[max_n][max_n];

bool isRed(int x, int y,int tol)
{
    if (abs(picture[x][y] - picture[x-1][y-1]) > tol)
    {
        if (abs(picture[x][y] - picture[x-1][y ]) > tol)
        {
            if (abs(picture[x][y] - picture[x - 1][y + 1]) > tol)
            {
                if (abs(picture[x][y] - picture[x][y + 1]) > tol)
                {
                    if (abs(picture[x][y] - picture[x + 1][y - 1]) > tol)
                    {
                        if (abs(picture[x][y] - picture[x + 1][y]) > tol)
                        {
                            if (abs(picture[x][y] - picture[x + 1][y + 1]) > tol)
                            {
                                return true;
                            }
                        }
                    }
                }
            }
                
        }
    }
    return false;
}

int main()
{
    int n,m,tol;
    map<int, int> countcolour;
    vector<candiate> can;
    scanf("%d %d %d", &m, &n, &tol);
    fill(picture[0], picture[0] + max_n * max_n, -10000);
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= m; j++)
        {
            scanf("%d", &picture[i][j]);
            countcolour[picture[i][j]]++;
            if (abs(picture[i][j] - picture[i][j - 1])> tol)
            {
                
                    temp.x = i;
                    temp.y = j;
                    can.push_back(temp);
                
                
            }
        }
    }
    int num = 0;
    int x, y;
    for (int i = 0; i < can.size(); i++)
    {
        if (isRed(can[i].x, can[i].y, tol) && countcolour[picture[can[i].x][can[i].y]] == 1)
        {
            num++;
            x = can[i].x;
            y = can[i].y;
        }
    }
    if (num == 0)
    {
        printf("Not Exist");
    }
    else if (num == 1)
    {
        printf("(%d, %d): %d", y, x, picture[x][y]);
    }
    else
    {
        printf("Not Unique");
    }
    return 0;
}

总结

注意审题,题目有说独一无二的点,所以需要记录元素出现的次数。一开始想着是开一个很大的数组,结果很容易就空间不足,后面上网看了一下发现可以用map,于是解决了第一个问题。测试点3、5是一开始没考虑边界(第1行、第m行,第1列、第n列),后面想到可以开一个(M+1)X(N+1)的数组存放矩阵,而第0行第0列与第M+1行和N+1列存放一个很大的负数,这样就能满足边界点的判定。(如(1,1)与左上角的判定,由于左上角没有元素,是一定要返回true的)

上一篇:1068. 寻找数组的中心索引


下一篇:【LeetCode】【数组】题号:*520. 检测大写字母