1007-3_4计算无限序列

3_4计算无限序列

Time Limit:1000MS Memory Limit:65536K
Total Submit:3872 Accepted:2523

Description

输入一个正整数n,计算1-1/4+1/7-1/10+1/13-1/16+…的前n项之和,输出时保留3位小数。

Input

正整数n (1≤n≤20)

Output

结果保留3位小数。

Sample Input

3
Sample Output

0.893
Source

#include<stdio.h>
#include<math.h>
int main()
{
	int a, b;
	double j=0;
	scanf("%d", &a);
	if (a > 1)
	{
		for (b = 1; b <= a; b++)
			j = j + pow(-1, b - 1.0) * (1.0 / (3.0 * b - 2));
	}
        else
            j = j + 1.0;
	printf("%.3f", j);
	return 0;
}
上一篇:[1007]倍杀测量者 题解


下一篇:leetcode 1584.连接所有点的最小费用