hdoj 1513 Palindrome【LCS+滚动数组】

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3918    Accepted Submission(s):
1340

Problem Description
A palindrome is a symmetrical string, that is, a string
read identically from left to right as well as from right to left. You are to
write a program which, given a string, determines the minimal number of
characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be
transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer
than 2 characters does not produce a palindrome.

 
Input
Your program is to read from standard input. The first
line contains one integer: the length of the input string N, 3 <= N <=
5000. The second line contains one string with length N. The string is formed
from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and
digits from '0' to '9'. Uppercase and lowercase letters are to be considered
distinct.
 
Output
Your program is to write to standard output. The first
line contains one integer, which is the desired minimal number.
 
Sample Input
5
Ab3bd
 
Sample Output
2
题意:最少向字符串中添加几个字符可以使该字符串变成回文字符串
题解:将字符串反转,跟原字符串使用LCS,算出最长公共子序列长度,拿总长度减去最长公共子序列长度就是答案
#include<stdio.h>
#include<string.h>
#define MAX 5010
#define max(x,y)(x>y?x:y)
char s1[MAX],s2[MAX];
int dp[2][MAX];
int main()
{
int i,j;
int t;
while(scanf("%d",&t)!=EOF)
{
scanf("%s",s1);
for(i=t-1,j=0;i>=0;i--)
s2[j++]=s1[i];
memset(dp,0,sizeof(dp));
for(i=1;i<=t;i++)
{
for(j=1;j<=t;j++)
{
dp[0][j]=dp[1][j];
dp[1][j]=dp[2][j];
if(s1[i-1]==s2[j-1])
dp[1][j]=dp[0][j-1]+1;
else
dp[1][j]=max(dp[1][j-1],dp[0][j]);
}
}
printf("%d\n",t-dp[1][t]);
}
return 0;
}

  

上一篇:GridView 设置背景透明以及Item的点击动画


下一篇:sed基本常用命令