C语言合法标识符
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45522 Accepted Submission(s): 18355
Problem Description
输入一个字符串,判断其是否是C的合法标识符。
Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
Sample Input
3
12ajf
fi8x_a
ff ai_2
Sample Output
no
yes
no
Author
lcy
#include <iostream>
#include <stdio.h>
#include <cstring> using namespace std; int main()
{
char a[60];
int n;
while (cin >>n)
{
getchar();
while (n--)
{
int flag = 0;
gets(a);
int p = strlen(a);
if ( !(a[0] == '_' || (a[0] >='a' && a[0] <='z') ||( a[0] >='A' && a[0] <='Z')))
cout << "no" <<endl;
else
{
for (int i=1; i<p; i++)
{
if ( !(a[i] == '_' || (a[i] >='a' && a[i] <='z') ||( a[i] >='A' && a[i] <='Z') || ( a[i] >= '0'&& a[i] <='9')))
flag++;
}
if (flag==0)
cout << "yes" << endl;
else
cout << "no" << endl;
}
}
}
return 0;
}