Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

深度搜索水题,AC代码

#include<iostream>
#include<string>
using namespace std;
char amap[25][25];
int to[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};
int w,h,cnt;
void dfs(int di, int dj)
{
    cnt++;
    amap[di][dj] = '#';
    for(int i = 0; i < 4; i++)
        if((di + to[i][0] >= 0) && (di + to[i][0] < h) && (dj + to[i][1] >= 0) && (dj + to[i][1] < w) && amap[di + to[i][0]][dj + to[i][1]] != '#')
            dfs(di + to[i][0] , dj + to[i][1]);
}
int main()
{
    while(~scanf("%d%d",&w,&h) && !(w == 0 && h == 0))
    {
        getchar();
        int di,dj;
        for(int i = 0; i < h; i++){
            for(int j = 0; j < w; j++)
            {
                amap[i][j] = getchar();
                if(amap[i][j] == '@')
                {
                    di = i;
                    dj = j;
                }
            }
            getchar();
        }

        dfs(di,dj);
        printf("%d\n",cnt);
        cnt = 0;
    }
    return 0;
}
上一篇:java上传图片


下一篇:android 安全退出应用程序的几种方法