H - A Simple Triangle --pe到si

In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column

should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases. 
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.

Output

For each test case, print out the triangle. the triangle separated by a blank line. 
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don't need print space. 

Sample Input

3
5
6
7

Sample Output

1  2  3  4  5
2  4  6  8
3  6  9
4  8
5

1  2  3  4  5  6
2  4  6  8  10
3  6  9  12
4  8  12
5  10
6

1  2  3  4  5  6  7
2  4  6  8  10 12
3  6  9  12 15
4  8  12 16
5  10 15
6  12
7

Hint

阅读理解读不好的人真的要哭,pe到si的那种

提示很简单,格式要注意!!!!首先如果输出的值<=9,要输出两个空格,>9输出一个空格,最后一个数字不输出空格,还要注意,每两组用空行隔开,最后一行不输出空行;

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n-i+1; j++)
            {
                printf("%d",i*j);
                if(i*j>9&&j!=n-i+1)
                    printf(" ");
                if(i*j<=9&&j!=n-i+1)
                    printf("  ");
            }
            printf("\n");
        }
        if(t!=0)
        printf("\n");
    }
}

 

上一篇:matplotlib颜色,线条,mark点


下一篇:Pascal's Triangle - LeetCode