POJ 1269 Intersecting Lines

POJ 1269 Intersecting Lines

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read “END OF OUTPUT”.

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

模板题,判断两条直线的位置关系:

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
typedef long long ll;
double eps=1e-8;
struct point{
double x,y;
point(double a=0,double b=0) {x=a; y=b;}
};

struct line{
    double a,b,c;
    line(double d1=1,double d2=-1,double d3=0) {a=d1;b=d2;c=d3;}
};

int lineintersect(line l1,line l2,point &p){//判两直线相交,相交返回交点p
double d=l1.a*l2.b-l2.a*l1.b;
if(fabs(l1.a*l2.b-l1.b*l2.a)<eps && fabs(l1.b*l2.c-l1.c*l2.b)<eps && fabs(l1.a*l2.c-l1.c*l2.a)<eps) return -1;
if(fabs(d)<eps)
return 0;
p.x=(l2.c*l1.b-l1.c*l2.b)/d;
p.y=(l2.a*l1.c-l1.a*l2.c)/d;
return 1;
}

line makeline(point p1,point p2){
line L;//确定的直线
int sign =1;
L.a=p2.y-p1.y;
if(L.a<0){
    sign=-1;
    L.a=sign*L.a;
}
L.b=sign*(p1.x-p2.x);
L.c=sign*(p1.y*p2.x-p1.x*p2.y);
return L;
}

int main()
{
    int t;
    cin>>t;
    puts("INTERSECTING LINES OUTPUT");
    while(t--){
        point p1,p2,p3,p4,p;
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&p1.x,&p1.y,&p2.x,&p2.y,&p3.x,&p3.y,&p4.x,&p4.y);
        line l1,l2;
        l1=makeline(p1,p2);
        l2=makeline(p3,p4);
        if(lineintersect(l1,l2,p)==-1) puts("LINE");
      	else  if(lineintersect(l1,l2,p)) {
            printf("POINT %.2f %.2f\n",p.x,p.y);
        }
        else puts("NONE");
    }
    puts("END OF OUTPUT");
    return 0;
}
POJ 1269 Intersecting LinesPOJ 1269 Intersecting Lines 旺 崽 发布了235 篇原创文章 · 获赞 13 · 访问量 2万+ 私信 关注
上一篇:linux-bash:如何从文件中提取数千行非顺序行


下一篇:idHttpServer接收类型