1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
 

Sample Output 1:

nyan~
 

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T
 

Sample Output 2:

nai

注意getline对回车键的读入

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int main(){
    int n;
    scanf("%d\n",&n);//注意:一定要加\n  ;  如果发现输出少了,一定要检查是否读入空格
    string str,ans;
    for(int i=0;i<n;i++){
        getline(cin,str);
        int lens=str.length();
        reverse(str.begin(),str.end());
        if(i==0){
            ans=str;
        }
        else{
            int lena=ans.length();
            if(lens<lena){
                swap(str,ans);
            }
            int len=min(lena,lens);
            for(int j=0;j<len;j++){
                if(str[j]!=ans[j]){
                    ans=ans.substr(0,j);//左闭右开
                    break;
                }
            }
        }
    }
    reverse(ans.begin(),ans.end());
    if(ans.length()>0){
            cout<<ans<<endl;
        }
        else{
            cout<<"nai"<<endl;
        }
    
    return 0;
}

 

上一篇:[LeetCode] 1035. Uncrossed Lines 不相交的线


下一篇:R语言中的多项式回归、局部回归、核平滑和平滑样条回归模型