PAT甲级1043 Is It a Binary Search Tree (25 分)

1043 Is It a Binary Search Tree (25 )

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7

8 6 5 7 10 8 11

Sample Output 1:

YES

5 7 6 8 11 10 8

Sample Input 2:

7

8 10 11 8 6 7 5

Sample Output 2:

YES

11 8 10 7 5 6 8

Sample Input 3:

7

8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意:

     二叉排序树BST其左孩子比他小,右孩子大于等于他,且为递归概念。给出n个结点以及其前序序列,要求判断是否为二叉排序树,或者是否为BST的镜像(即左右交换)。如果是则输出YES,下一行输出相应的后序序列。

 

 

思路:

      由于要求输出后序,那么按照二叉排序树的特点可以直接找出其后序序列。

    

参考代码:

#include<vector>
#include<cstdio>
using namespace std;
vector<int> pre, post;
bool mirror;
void getpost(int root, int ed){
	if(root > ed) return;
	int i = root + 1, j = ed;
	if(!mirror){
		while(i <= ed && pre[i] < pre[root]) i++;
		while(j > root && pre[j] >= pre[root]) j--;
	}else{
		while(i <= ed && pre[i] >= pre[root]) i++;
		while(j > root && pre[j] < pre[root]) j--;
	}
	if(i - j != 1)	return;
	getpost(root + 1, j);
	getpost(i, ed);
	post.push_back(pre[root]);
}
int main(){
	int n;
	scanf("%d", &n);
	pre.resize(n);
	for(int i = 0; i <n; ++i)	scanf("%d", &pre[i]);
	getpost(0, n - 1);
	if(post.size() != n){
		mirror = true;
		post.clear();
		getpost(0, n - 1);
	}
	if(post.size() == n){
		printf("YES\n%d", post[0]);
		for(int i = 1; i < n; ++i)	printf(" %d", post[i]);
		return 0;
	}
	printf("NO\n");
	return 0;
}

代码参考:

https://blog.csdn.net/liuchuo/article/details/52160455

上一篇:蠡口95. Unique Binary Search Trees II


下一篇:二叉查找树的实现与讲解(C++)