PAT Ranking (25)

题目描述
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
输入
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
输出
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

样例输入 Copy
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
样例输出 Copy
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

#define _CRT_SECURE_NO_WARNINGS

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<stdbool.h>


typedef struct {
	char registration[15];
	int loc; int score;
	int locrank; int finrank;
}student;


student st[30005];

int cmp(const void* a, const void* b)
{
	student* a_ = (student*)a;
	student* b_ = (student*)b;
	if (a_->score != b_->score)return(b_->score - a_->score);
	else return strcmp(a_->registration , b_->registration)>0;
}

int main()
{
	int n; int num = 0;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++)
	{
		int k; scanf("%d", &k);
		for (int j = 1; j <= k; j++)
		{
			num++;
			scanf("%s %d", st[num].registration, &st[num].score);
			st[num].loc = i;
		
		}
		qsort(st + num - k+1, k, sizeof(student), cmp);

		for (int j = num - k+1 ; j <= num ; j++)
		{
			if (j == num - k+1  || st[j - 1].score != st[j].score)
			{
				st[j].locrank = j - num + k;
			}
			else st[j].locrank = st[j-1].locrank;
		}

	}

	qsort(st+1, num, sizeof(student), cmp);
	for (int i = 1; i <= num; i++)
	{
		if (i == 1 || st[i - 1].score != st[i].score) {
			st[i].finrank = i;
		}
		else st[i].finrank = st[i - 1].finrank;
	}
	printf("%d\n", num);
	for (int i = 1; i <= num; i++)
	{
		printf("%s %d %d %d\n", st[i].registration, st[i].finrank, st[i].loc, st[i].locrank);
	}
}

PAT Ranking (25)

上一篇:已创建的docker容器修改run时的参数


下一篇:2021 Navicat Premium 15 激活教程