实验2-4-6 求幂之和 (15 分)

本题要求编写程序,计算sum=2¹+2²+2³+⋯+2ⁿ 。可以调用pow函数求幂。

输入格式:

输入在一行中给出正整数n(≤10)。

输出格式:

按照格式“result = 计算结果”输出。

输入样例:

5

输出样例:

result = 62

#include<stdio.h>
#include<math.h>
int main()
{
	int a,b;
	scanf("%d",&b);
	int max = 0.0;
	for ( a=1 ; a<=b ; a++){
		max += pow(2,a);
	}
	printf("result = %d",max);
	return 0;
 } 
上一篇:打印出100-999所有的“水仙花数“,所谓“水仙花数“是指一个三位数, 其各位数字立方和等于该数本身。


下一篇:每日LeetCode - 7. 整数反转(C语言和Python 3)