HDU 1241 Oil Deposits(DFS)

Oil Deposits

原题链接:HDU 1241

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.


Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.


Sample Input

HDU 1241  Oil Deposits(DFS)

Sample Output

0
1
2
2


题解:

题意:

有一块地,判断油田的个数,@代表油田,如果几块油田相邻则表示一块油田。

AC代码

#include<iostream>
#include<string.h>

using namespace std;
char a[105][105];
int ne[105][105];
int m,n;


void dfs(int x,int y,int num) {
    if(x >= m || y >= n || x < 0 || y  < 0)
        return;
    if(ne[x][y] > 0 || a[x][y] != '@')
        return;
    ne[x][y] = num;
    for(int i = -1; i <= 1; i++)
        for(int j = -1; j <= 1; j++)
            dfs(x+i,y+j,num);
}
int main() {
    std::ios::sync_with_stdio(false);

    while(cin>>m>>n && m != 0) {
        memset(ne,0,sizeof(ne));
        int cunt = 0;
        for(int i = 0; i < m; i++)
            cin>>a[i];
        for(int i = 0; i < m; i++)
            for(int j = 0; j  < n; j++)
                if(ne[i][j] == 0 && a[i][j]=='@')
                    dfs(i,j,++cunt);
        cout<<cunt<<endl;
    }
    return 0;
}

上一篇:CF238E Meeting Her


下一篇:HDU 1712